Pureinfotech Forums

How to fix unable to format Seagate hard drive on Windows 10

Trying to do my first ever format of a new internal HDD. It’s a Seagate Barracuda 1TB. Sadly for me I was clueless to begin with, stupidly thinking I could immediately install windows from a Windows Media Creation Tool usb drive. Obviously you can’t and I have steadily made things worse trying to learn and fix the issue.

I have it connected to a laptop and also tried a pc using a powered sata external usb 3 lead. It no longer appears in disk manager (disk manager won’t even open with it connected) or now even diskpart. I keep thinking I’ve bricked the drive, however in Powershell, it shows as healthy and online. I have cleaned it and initialized it.

Last night I even managed to assign a drive letter (hallelujah a message popped up asking what I wanted to do with drive E) and a 10gb partition. The issue is formatting. It never works. Now I can actually see it, right clicking in explorer and trying a quick format fails.

Powershell throws an invalid parameter error. Yesterday it was not enough space. Eventually the drive stops windows doing anything (black screen) until the drive is unplugged then everything works fine. Unplugging it when running is a bad mistake I know but the only way to move forward that I know. Any helpful suggestions welcome and much appreciated. :pray:t2:

image

If you already tried using PowerShell to clean and format the drive as shown in this guide, then you may want to try using Gparted on Linux to see if you can format the drive.

You can use this guide as a reference (only) to get to know the tool. Bassically, you want to create a live cd, boot the device with the hard drive in question, and try to delete and recreate the partitions. If it works, then you can reformat the drive again on Windows 10 to make sure that everything is working OK.

Warning: Use the suggestions as your own risk. Selecting the wrong drive, you could end up deleting the incorrect information.