Pureinfotech Forums

Windows 10 proxy settings won't save for Wi-Fi


#1

Hello guys!
There is my problem:
From PC I’m easily set up proxy for any browsers (Settings > Network & Internet > Proxy > Manual proxy setup), but then I trying to do the same on laptop it doesn’t work at all - OK/Save button just not clickable.
What I’m doing wrong?


#2

To quickly get around this proxy issue on Windows 10, use these steps:

  1. Open Control Panel.
  2. Click on Network and Internet.
  3. Click on Internet Options.
  4. Click the Connections tab.
  5. Click the LAN settings button.
  6. Configure the proxy settings.

These steps should be able to get you going with the settings you need.


#3

Result the same - OK button not clickable. I tried to check all check boxes, it doesn’t help.


#4

Use this command in elevated mode to reset the proxy settings, any settings were previously applied:

netsh winhttp reset proxy


#5

It didn’t help:(
Current WinHTTP proxy settings:
Direct access (no proxy server).


#6

If you create another user account in the same computer, do you see the same problem?


#7

Yes, I have the same problem.


#8

What’s the version of Windows 10 and update number that your PC is running? Hint: Use winver command in Command Prompt.


#9

Windows 10 Home
1809 (17763.316)


#11

Method 1:
Use this guide to reset your network adapter on Windows 10, and see if you can save the proxy settings. (Read the warning in the guide before proceeding.)

Method 2:
If that doesn’t work, look for “Identify and repair network problems” in the Start menu, and use the Network Troubleshooter to see if it fixes the proxy issue.


#12

Hello!
First method didn’t help me.
Second method showed me the problem: “Windows could not automatically detect this network’s proxy settings.”
I started research in internet, tried a few methods witсh didn’t help me and finally found the solution:
To people who when they press OK nothing happens. and They did not find ProxySettingsPerUser, go to : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinHttpAutoProxySvc
find name “Start” and click modify then change the value to number 2
restart your machine.

Now I can use proxy:) Thank you for your answers and advises!


#13

Awesome! Glad to hear the proxy settings are working again.
Thanks for sharing the findings.